FANDOM


  • I heard somewhere that all anchors, teleport teather, world anchor, and dimensional anchor have a serious glitch that causes you to have to delete the entire world and start over just to get rid of them.  That mining them up doesn't remove them.  Is this true?

    Also, what distance does a player tend to have when they are on? a 9x9 chunk area?  Or is it larger?

      Loading editor
    • Yes this is called, corruption. It corrupts that specific world, and you have to start all over again. This even happens in multiplayer. That's why on most servers this block and his "companion" blocks are banned. For causing latency and corruption.

        Loading editor
    • VasVadum
      VasVadum removed this reply because:
      my post again, because your system refuses to keep me logged in.
      21:23, December 20, 2012
      This reply has been removed
    • How does this happen? I have a dimensional anchor under my home right now to keep the power flowing at all times and to keep my stuff working.

      Can anchors be removed before any corruption happens?  If I pickaxe my anchor down, does the anchor stop functioning?

        Loading editor
    • I've never had an issue with world anchor corrupting maps, but have had the teleport teather do so. Can't speak for dimensional anchor since I don't use it.

      I run an SMP server, and we use world anchors a lot. I put them down and pick them up quite frequently (and have a machine that does the same with the minecart version from railcraft). Every time I pump oil wells off with wireless pipes, send an MFS cart down the rail system, or use a tunnel bore, one is used (and removed when finished).

      Latency / lag isn't really a bug...IMO it seems more like something to be expected. The game normally manages its load by unloading chunks when they aren't needed. Anchors defeat this.

        Loading editor
    • Wait, what? I cannot even craft this thing in the later versions of Technik pack. Why is this even on here?

        Loading editor
    • They took achors out?  well that sucks.  And not technic, tekkit.  Just a heads up on what we were talking about.

        Loading editor
    • VasVadum wrote:
      They took achors out?  well that sucks.  And not technic, tekkit.  Just a heads up on what we were talking about.

      All anchers and tethers are still in Tekkit.

        Loading editor
    • How can I tell exactly what area is being affected by my Dimensional Anchor? Does it start with the chunk it's in then go in a certain direction, or put itself in the middle of the protection and go out equally in all directions?

        Loading editor
    • It expands out in all directions.  If you have a Dimensional anchor set to 9x9, it'll go out 4 chunks in all directions + the middle chunk.

        Loading editor
    • Not directly related to this thread, but I kept finding it while googling my problem.

      To edit Dimensional Anchor settings, go to config/immibis.cfg. Of interest is chunkloader.maxChunksPerPlayer, which defaults to 3.

        Loading editor
    • no clue, you can start your own thread easily too

        Loading editor
    • The recipe is wrong, you need a ender pearl in the middle. I was searching for a bug but is not.

        Loading editor
    • R2D2Droid wrote:
      The recipe is wrong, you need a ender pearl in the middle. I was searching for a bug but is not.

      Are you using Tekkit Lite or something? Ender pearl does not work on Tekkit Classic, 3 obsidian work.

        Loading editor
    • i didnt know anchors can corrupt a world, can someone tell me is this true? i was planning to load some chunk using this and now this thread make me scared to do so

      Even better, can someone tell me how can i prevent it from corrupting a world and what make it corrupt a world?

        Loading editor
    • I so far have not found any problems with world anchors or dimensional anchors corrupting worlds, on either my server, others', or my single player worlds. I can't say anything about the teleport tether as I so far have never used one.

      The only bug I've so far found, is that trying to open the dimensional anchor's GUI while using a jetpack will crash your client. Other than that I haven't found any problems yet.

        Loading editor
    • World anchors or dimensional anchors does not work for me in singleplayer world. I heard a lot of you saying that it works for you but not for me. Help?

        Loading editor
    • it wont work in singleplayer.... only in multiplayer

        Loading editor
    • It works in singleplayer to keep chunks loaded when you are otherwise too far away, NOT while you are logged out of the game.

        Loading editor
    • I am logged in and have a world anchor in the nether to transport buckets backwards and forwards and the world anchor is not keeping it loaded. Any ideas? (singleplayer)

        Loading editor
    • 81.157.235.191 wrote:
      I am logged in and have a world anchor in the nether to transport buckets backwards and forwards and the world anchor is not keeping it loaded. Any ideas? (singleplayer)

      I don't think it works between dimensions but i am not sure as i have never tried it.

      Hope this helps

        Loading editor
    • It does work between dimensions however as I was dumping a bucket of energized glowstone onto it, it opened the GUI for the world anchor, froze my game, crashed it, reset the data in tekkit, then corrupted my world :/ I don't know if its liquids in general or just me opening it, but if there is a fix I'd love to hear it XD

        Loading editor
    • Not Exactley "Start Over" If You Go Into MCedit You Can Copy The Entire World To A ".Scmatic" File Then You Can Create A New World And Paste In The Scmatic File!


      You Will Lose Your Inventory And All Contents In Any Alcomy Bags,Enderchests,Enderbags,Any Data That Is Not Been Placed Or Droped Inside The World

      But Apart From That

      WORLD RECOVERED! :D

        Loading editor
    • Eareos
      Eareos removed this reply because:
      I
      21:38, September 8, 2013
      This reply has been removed
    • Eareos wrote:
      Not Exactley "Start Over" If You Go Into MCedit You Can Copy The Entire World To A ".Scmatic" File Then You Can Create A New World And Paste In The Scmatic File!


      You Will Lose Your Inventory And All Contents In Any Alcomy Bags,Enderchests,Enderbags,Any Data That Is Not Been Placed Or Droped Inside The World

      But Apart From That

      WORLD RECOVERED! :D

      Or just make a back-up.

        Loading editor
    • WaffletimeCat wrote:
      It does work between dimensions however as I was dumping a bucket of energized glowstone onto it, it opened the GUI for the world anchor, froze my game, crashed it, reset the data in tekkit, then corrupted my world :/ I don't know if its liquids in general or just me opening it, but if there is a fix I'd love to hear it XD

      Ummm... Energized Glowstone is from Thermal Expansion, which is certainly not in TC. I don't know what to tell you...

      Also, the crash may be simply a level.dat deletion. You'll lose your items, difficulty, etc., but you can copy a new one into it.

      Or, you're playing with Optifine. It hates anything relate to CB

        Loading editor
    • I think the world anchor is from railcraft



      Dave 

        Loading editor
    • 71.227.149.43 wrote:
      I think the world anchor is from railcraft



      Dave 

      Yes, yes it is. But, if you're playing with Optifine and ANY ChickenBones mod (such as NEI), you're, in layman's terms, screwed.

        Loading editor
    • Malsf21 wrote:
      71.227.149.43 wrote:
      I think the world anchor is from railcraft


      Dave 

      Yes, yes it is. But, if you're playing with Optifine and ANY ChickenBones mod (such as NEI), you're, in layman's terms, screwed.

      I think optifine is buggy. Don't know why the nei would mess it up though.

      Dave

        Loading editor
    • 71.227.149.43 wrote:
      Malsf21 wrote:
      71.227.149.43 wrote:
      I think the world anchor is from railcraft


      Dave 

      Yes, yes it is. But, if you're playing with Optifine and ANY ChickenBones mod (such as NEI), you're, in layman's terms, screwed.
      I think optifine is buggy. Don't know why the nei would mess it up though.

      Dave

      Dave, it's because Optifine didn't change it's rendering process when forge did, causing many items calling a specific function to fail and crash the game.

        Loading editor
    • VasVadum wrote:
      How does this happen? I have a dimensional anchor under my home right now to keep the power flowing at all times and to keep my stuff working.

      Can anchors be removed before any corruption happens?  If I pickaxe my anchor down, does the anchor stop functioning?

      Yes, yes. They stop the force loading of chunks when broken.

        Loading editor
    • To anyone in who experinces corruption of there world there is an easyer way to fix it then starting all over.

      You can use MCEdit to ether delete the entity (i.e a anchor) that is causing the crash, or if a chunk is corrupted you can reset that specif chunk tho this will option will cause anything build inside the chunk to disappear.

        Loading editor
    • Hi guys, I recently made a world anchor and put it down to keep my EMC farm running. I read on the wiki the range of the world anchor is 3x3 chunks, but when I left the chunk for a while and came back the chunk had to be reloaded (meaning it wasn't already loaded) and the EMC farm had not been running while I was AFK in the other chunk. I also read you could press F9 to see what area is loaded by the world anchor but when I press F9 nothing happens (and yes the controls are correct) Please Help!!!!!

        Loading editor
    • Correction: I was stupid and realized the key was F12 not F9. The particles show now but the chunk still doesn't stay loaded!

        Loading editor
    • LegendaryZX wrote:
      Correction: I was stupid and realized the key was F12 not F9. The particles show now but the chunk still doesn't stay loaded!

      Next time, start a new thread instead of adding on to an old thread.

      If you're playing Singleplayer, it's quite worthless; it only works on SMP. Should you be on a public server, they might have plugins which disable the affects of a World Anchor. You can press F9 TWICE to see the chunk boundaries around you; Green means loaded, and Red means unloaded.

        Loading editor
    • Oh... Thank you I did not know they didn't work in Singleplayer. Thanks for the clarifications!

        Loading editor
    • LegendaryZX wrote:
      Oh... Thank you I did not know they didn't work in Singleplayer. Thanks for the clarifications!

      No problemo.

      It does work in SSP, but only if the world is OPEN. So, you could go AFK if you really, really wanted those chunks to keep on doing their stuff.

        Loading editor
    • Malsf21. By open do you mean LAN?

        Loading editor
    • 86.31.198.201 wrote:
      Malsf21. By open do you mean LAN?

      SSP is LAN. Not an open world.

        Loading editor
    • 86.31.198.201 wrote:
      Malsf21. By open do you mean LAN?

      Open as in you are actively in the world, and you minimize the window.

      LAN does work... I guessssss

        Loading editor
    • Well im kinda worried since i placed a world anchor in my world and some of the textures on blocks have broken for instince coal will look like uranium and my reinforced stone has a rose on the face it and my floors looks like its on fire im not sure if this is because of my world anchors or lamps or because of the autocrafter i have there cause i placed them all at the same time. also i forgot to add it only looks like it from a certain angle

        Loading editor
    • 2014-08-23 18.42.13

      Thats what im talking about.

        Loading editor
    • Wow! You should try re-installing the game.

      Do you have any sort of Texture pack iinstaled? Are you playing on a server?

        Loading editor
    • Nope ive been playing 100% vanilla not even on a server

        Loading editor
    • i meant 100% ligit not vanilla

        Loading editor
    • Okay, so reinstall the modpack. That'd help out a lot, maybe your computer downloaded stuff incorrectly.

        Loading editor
    • i dont its how it downloaded cause its only been doing it within the past week

        Loading editor
    • Justaname77 wrote:
      i dont its how it downloaded cause its only been doing it within the past week

      Go to your .technic folder (in your AppData folder), go to tekkitmain, and delete everything. You might want to save a copy somewhere else.

      Then, just re-install TC.

        Loading editor
    • A FANDOM user
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message
Community content is available under CC-BY-SA unless otherwise noted.